28th January 2019

Content services Nearpod Library slowdown

We are investigating issues with the Nearpod Library.

Based on our monitors, we are seeing slowdowns and errors stemming from a caching server.

The engineering team is investigating the root cause and will update shortly.

Update 9:34 am - We have restarted the slow cache server and performance is recovering.

Update 10:00 am - Nearpod apps have returned to normal operation as of 9:35 am.