25th April 2019

Account services Slowdowns on login page

We are investigating an issue on our login page due to an load related issue with our cache server.

Update 5:15 pm ET - We are failing over to our fallback caching server after identifying an issue on one of caching servers.

Update 5:17 pm ET - Failover complete and performance is improving. We will continue to monitor the clusters for any additional impacts or issues.