30th March 2020

Reporting module Nearpod Quiz and Matching Pair results are taking longer than normal to display in teacher dashboards

We are monitoring delays in posting Quiz and Matching pair results to the teacher dashboard. This is due to increased server load.

Update 1:05 pm ET - We are adding additional servers to respond to the load.

Update 2:05 pm ET - Quiz and matching pair results are posting to teachers dashboards but may still show some minor delays

Update 3:05 pm ET - We continue to monitor Quiz and Matching Pair submissions. Processing is stable.

Update 4:05 pm ET - Matching pair submissions have returned to normal. We continue to monitor Quiz submissions

Update 5:05 pm ET - Quiz results are continuing to be processed. Some are running approximately 30 minutes delayed.

Update 6:05 pm ET - We are deploying updates to the platform this evening to increase the speed of processing for Quiz and Matching Pair submissions.

Update 11:45 pm ET - We have deployed platform updates to increase processing speed of Quiz and Matching Pair submissions, and will continue to monitor processing times this week.