Issues accessing Nearpod
Incident Report for Nearpod
Resolved
This incident has been resolved. All impacted components are functional.
Posted Apr 25, 2024 - 17:19 EDT
Monitoring
The issue have been resolved and service is restored; we continue to monitor closely.
Posted Apr 25, 2024 - 16:49 EDT
Update
We are continuing to work to remediate the issue as quickly as possible.
Posted Apr 25, 2024 - 16:23 EDT
Identified
We have identified the issue and working quickly to restore service.
Posted Apr 25, 2024 - 15:47 EDT
Investigating
There are currently issues accessing Nearpod, we are actively investigating.
Posted Apr 25, 2024 - 15:46 EDT
This incident affected: Login, Content Creation, Content Delivery, and Reporting.