Performance and Loading Issues with Nearpod

Incident Report for Nearpod

Resolved

Normal loading times remained restored and system is behaving as expected. We will continuing to monitor closely.
Posted May 12, 2022 - 13:45 EDT

Monitoring

Normal loading times have been restored. We are continuing to monitor closely.
Posted May 12, 2022 - 13:19 EDT

Investigating

Nearpod is experiencing long loading times and we are actively investigating the issue.
Posted May 12, 2022 - 13:16 EDT
This incident affected: Login, Content Creation, and Content Delivery.