Issues with presentations saving slowly
Incident Report for Nearpod
Resolved
All issues with the performance of saving lessons remain remedied, and we've continued to monitor. This incident now marked resolved.
Posted Dec 14, 2020 - 10:59 EST
Monitoring
Performance for saving presentations should be restored for all users. We continue to monitor our systems.
Posted Dec 14, 2020 - 10:54 EST
Update
Performance for saving presentations should be restored for users. We will continue to monitor.
Posted Dec 14, 2020 - 10:52 EST
Identified
We have identified the issue with slow presentation saving and are in process of remediating.
Posted Dec 14, 2020 - 10:34 EST
Investigating
We are investigating an issue with presentation saving taking longer than usual. Updates to follow.
Posted Dec 14, 2020 - 10:19 EST
This incident affected: Content Creation.