Issues with Nearpod platform related to broad internet/cloud provider issues
Incident Report for Nearpod
Resolved
We are seeing overall improvement with regards to the major cloud provider issues broadly impacting the internet and impeding users ability to access Nearpod. We will continue to monitor closely and ensure normal operation remains restored.
Posted Jun 13, 2023 - 17:06 EDT
Monitoring
We are starting to see improvement with regards to the major cloud provider issues broadly impacting the internet and impeding users ability to utilize Nearpod. Users may still experience intermittent issues accessing our service, however, we continue to monitor closely and provide all the support we can.
Posted Jun 13, 2023 - 16:54 EDT
Update
We continue to investigate this issue and implement mitigations, however, be aware of major cloud provider issues broadly impacting the internet that may affect your ability to reach Nearpod.
Posted Jun 13, 2023 - 16:19 EDT
Update
We continue to investigate this issue and implement mitigations, however, be aware of major cloud provider issues broadly impacting the internet that may affect your ability to reach Nearpod.
Posted Jun 13, 2023 - 16:11 EDT
Identified
Users may have trouble reaching or successfully using Nearpod due to widespread internet and cloud provider issues being experienced by AWS. We are actively investigating and working to mitigate/remedy any issues.
Posted Jun 13, 2023 - 15:53 EDT
This incident affected: Login, Content Creation, Content Delivery, and Reporting.