Issue saving lessons with Google Slides
Incident Report for Nearpod
Resolved
This incident has been resolved.
Posted Feb 21, 2023 - 13:59 EST
Investigating
We are currently investigating an issue where users are intermittently unable to save lessons created with Google Slides
Posted Feb 21, 2023 - 09:44 EST
This incident affected: Content Creation.