Nearpod Google Slides Add-on unavailable due to Google outage.
Incident Report for Nearpod
Resolved
The issue has been resolved within Google, but we will continue to monitor.
Posted Jan 15, 2025 - 16:35 EST
Monitoring
Currently, the Google Slides Add-on is displaying a blank screen when users try to access it for creating or editing lessons. Our team investigated the issue and found it to be related to an issue identified on Google's side. We will continue to monitor and will update as soon as we have additional information.
Posted Jan 15, 2025 - 14:19 EST
This incident affected: Content Creation.