Possible blank screens when attempting to join a lesson.
Incident Report for Nearpod
Resolved
Normal operating continues to be restored and the issue is resolved. We will continue to monitor closely to ensure no further issues.
Posted Sep 29, 2023 - 14:04 EDT
Update
The issue appears largely resolved and we continue to monitor closely to ensure full functionality is restored for all users.
Posted Sep 29, 2023 - 12:55 EDT
Monitoring
We have released a fix and continue to monitor and diligently work to make sure all teachers and students are able to join their lessons reliably. We will continue to monitor and post updates until we are certain the situation is resolved.
Posted Sep 29, 2023 - 12:50 EDT
Identified
We are continuing to investigate the issue and our team is rapidly working to address it so we can get back to ensuring teachers have the seamless Nearpod experience they are accustomed to. We hope to have this issue addressed soon.
Posted Sep 29, 2023 - 11:17 EDT
Update
We are continuing to investigate the issue and our team is rapidly working to address it so we can get back to ensuring teachers have the seamless Nearpod experience they are accustomed to. We hope to have this issue addressed soon.
Posted Sep 29, 2023 - 10:25 EDT
Investigating
We have been made aware of an issue where some users see a blank screen when joining a lesson. Teachers and students are at the center of everything we do, and our team is actively working to identify the cause of this issue so we can get back to ensuring teachers have the seamless Nearpod experience they are accustomed to. We hope to have this issue addressed soon. In the meantime, you can try these steps:

- Refresh the browser screen, it may take several attempts.
- Close additional browser tabs or applications open on the device.
Posted Sep 29, 2023 - 10:19 EDT
This incident affected: Content Delivery.