Issues accessing Nearpod (from US West Coast)
Incident Report for Nearpod
Resolved
Our provider has completed putting mitigations in place to remedy their network issue and access to Nearpod appears restored across all regions. We will continue to monitor closely.

https://www.cloudflarestatus.com/incidents/d4g3q6bqzfnr
Posted Feb 15, 2022 - 18:16 EST
Monitoring
Our provider has put mitigations in place to remedy their network issues and access to Nearpod is becoming restored. We are closely monitoring.

https://www.cloudflarestatus.com/incidents/d4g3q6bqzfnr
Posted Feb 15, 2022 - 17:55 EST
Identified
General networking issues have been resolved, but our provider may still be having intermittent issues with US West Coast traffic. We are continuing to work with them to resolve the issue.

https://www.cloudflarestatus.com/incidents/d4g3q6bqzfnr
Posted Feb 15, 2022 - 17:25 EST
Investigating
We are currently investigating an issue with a network provider that routes traffic to Nearpod. Nearpod may load slowly, or in some cases not at all. We are actively working with the provider to remedy the problem and restore all access to Nearpod through their network.
Posted Feb 15, 2022 - 17:18 EST
This incident affected: Login, Content Creation, Content Delivery, and Reporting.