Unable to create Google Slides lesson from within the Nearpod Lesson Library
Incident Report for Nearpod
Resolved
We have identified the source of the issue as an outage within Google Slides. The issue has been resolved within Google, but we will continue to monitor.

https://www.google.com/appsstatus/dashboard/incidents/ubuv1bKMuStaemGtqLb5
Posted Apr 17, 2023 - 17:23 EDT
Update
We are continuing to investigate this issue and will provide an update as soon as possible
Posted Apr 17, 2023 - 16:41 EDT
Investigating
Currently, users cannot create a Google Slides lesson from within the Nearpod Lesson Library. They can still create lessons with the Nearpod add-on for Google Slides as well as edit and launch lessons as expected
Posted Apr 17, 2023 - 15:51 EDT
This incident affected: Content Creation.