Issues saving edited lessons
Incident Report for Nearpod
Resolved
Lesson saving functionality remains restored and the issue is resolved. We will continue to monitor closely.
Posted May 15, 2024 - 10:55 EDT
Monitoring
We have implemented a fix and are closely monitoring to ensure functionality remains restored.
Posted May 15, 2024 - 10:49 EDT
Identified
We have identified the issue with saving lessons and are actively working to restore functionality.
Posted May 15, 2024 - 10:45 EDT
Investigating
Users may be experiencing issues saving lessons after editing, we are actively investigating.
Posted May 15, 2024 - 10:44 EDT
This incident affected: Content Creation.