Issues with Launching Lessons

Incident Report for Nearpod

Resolved

The issue is resolved. This incident is closed and we continue to monitor our systems.
Posted Nov 18, 2021 - 17:03 EST

Monitoring

We have identified the source of the problem and have resolved the issue. We are monitoring closely and will provide additional updates as needed.
Posted Nov 18, 2021 - 16:51 EST

Investigating

We are currently investigating an issue with launching lessons. Updates to follow.
Posted Nov 18, 2021 - 16:48 EST
This incident affected: Content Delivery.