Google Slides Add-On not working
Incident Report for Nearpod
Resolved
This incident has been resolved.
Posted Dec 08, 2020 - 12:42 EST
Monitoring
The Google Slides Add-On is working again. We have reached out to Google to remediate and will continue to monitor this feature.
Posted Dec 08, 2020 - 12:07 EST
Investigating
We are investigating an issue with the Nearpod Google Slides Add-On. While we’re working to resolve, teachers are still able to upload their Google Slides to Nearpod by using the lesson builder on nearpod.com. Here's how: https://bit.ly/33SHL7B
Posted Dec 08, 2020 - 09:01 EST
This incident affected: Content Creation.