Performance slowness in Content Creation Tool / Login
Incident Report for Nearpod
Resolved
Update 7:15 pm ET: Nearpod services returned to normal performance at approximately 2:45 pm ET. Nearpod will continue monitoring and will post further details as the provider is still working to identify what specifically caused their service disruption.

Update 2:15 pm ET: Nearpod’s cloud provider is experiencing issues. We are working with them to identify a resolution, however until then, both teachers and students may have trouble accessing Nearpod. We sincerely apologize, and will provide an update as soon as our provider resolves the issue.

Update 1:35 pm ET: We have identified an issue with a service provider and are currently working with them to resolve the issue.

Update 12:35 pm ET: We are continuing to investigate. Users may see intermittent or slow access to both login and the Content Creation Tool at this time.

We are currently investigating slowness in the Content Creation Tool. Access to user's nearpod libraries may be slow during this time.
Posted Sep 09, 2020 - 15:00 EDT