Issue accessing Nearpod
Incident Report for Nearpod
Resolved
Nearpod services continue to operate normally and any impact from issues at our cloud provider has subsided. We will continue to monitor closely.
Posted Mar 09, 2023 - 14:45 EST
Monitoring
Nearpod services appear to be back online and operating normally; we are monitoring closely.
Posted Mar 09, 2023 - 14:05 EST
Investigating
Users may have intermittent issues accessing Nearepod services, we are actively investigating.
Posted Mar 09, 2023 - 13:48 EST
This incident affected: Login, Content Creation, and Content Delivery.