Delays while saving lessons
Incident Report for Nearpod
Resolved
Issues with saving lessons are resolved and we'll continue to monitor.
Posted Oct 16, 2024 - 16:35 EDT
Monitoring
We have restored lesson saving functionality and are monitoring closely.
Posted Oct 16, 2024 - 16:30 EDT
Identified
Users may experience delays while saving newly created or edited lessons. We have identified the issue and are working quickly to remedy the issue.
Posted Oct 16, 2024 - 16:09 EDT
This incident affected: Content Creation.